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Overview of AIS Server  
  
AIS Server is a software tool for a wide range of AIS (Automatic Identification System) 
users. 
  
AIS Server connects AIS network nodes (AIS base stations/transponders/receivers, AIS 
services/clients, databases, and/or networks) and allows AIS messages to easily and 
efficiently flow from one node to another. It connects at least two nodes and sends each 
AIS message based on the current configuration of the nodes. You configure AIS Server 
to pass along certain messages to certain nodes on a network. AIS Server can also store 
all received AIS messages in the databases or text files. 
  
SiiTech has developed a modular and scalable AIS Server solution that meets the needs 
of all kinds of AIS users. For shore-based networks, AIS Server enables the flow of 
information from one or more isolated base stations to a Vessel Traffic Services (VTS) 
centre. With AIS Server all VTS centers may be joined in a regional or national AIS 
network. The distribution of AIS data (standard and proprietary messages) from one 
central location to shared locations makes AIS Server essential in many diverse 
environments. 
  
AIS Server performs a number of functions when data is passed into it; unlike hardware 
routers found on the internet that simply pass information from one network to another. 
AIS Server can filter data as it is received, and does not necessarily forward all received 
information. Nodes are allowed to forward and/or accept messages on a case by case 
basis. Proprietary message handling capability allows SiiTech to offer complete 
customization of AIS Server to meet your specific needs. 
  
The future of your network is dependant on the flow of information from all nodes (AIS 
transponders/receivers, users, databases, and/or networks). AIS Server provides a reliable 
flow of AIS data to your environment that is flexible and highly configurable. 
  
AIS Server designed to perform the following functions: 
  

 Receiving AIS messages from AIS transponders/receivers through serial ports 
 Receiving AIS messages from AIS transponders/receivers using TCP/IP, UDP, 

and SOAP protocols (e.g. through the Internet) 
 Sending AIS messages to AIS transponders through serial ports 
 Sending AIS messages to AIS transponders using TCP/IP protocol (e.g. through 

the Internet)  
 Sending AIS messages to other AIS servers or clients using TCP/IP, UDP , and 

SOAP protocols (e.g. through the Internet)  
 Supporting multiple TCP, UDP, and SOAP server/client connections  
 Supporting multiple serial port connections  
 Filtering AIS messages by IP addresses of clients 
 Filtering AIS messages by MMSI numbers 
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 Filtering AIS messages by geographical coordinates (latitude/longitude) 
 Saving AIS messages into the database or text file without any time or size limits 
 Ability to work as a service (e.g. when a computer is rebooted AIS Server starts 

automatically) 
  
  

 
 



 

Using AIS Server 
  
As the administrator it is important to understand the functionality of AIS Server as well 
as Web VTS. You should review the Web VTS User’s Guide in addition to this manual 
before administering AIS Server. It is also important to note that active users may be 
immediately affected by the changes you make while you are administering. 
  
AIS Server consists of the following services (processes): 
  

 COM Port service: Communicates with AIS devices through a serial port. 
 TCP/UDP/SOAP Server service: Receives AIS data from different sources and 

redistributes AIS data to different consumers through TCP or UDP or SOAP 
protocol. This process waits for clients and serves them. 

 TCP/UDP/SOAP Client service: Receives AIS data from different sources and 
redistributes AIS data to different consumers through TCP or UDP or SOAP 
protocol. This process establishes connection to servers and communicates with 
them. 

 Message Logger service: Stores AIS messages received by COM Port service or 
TCP/UDP/SOAP Server/Client service to the text file. 

 VTS Server service: Provides real-time AIS data to Web VTS. 
 AIS Database service: Stores AIS messages received by COM Port service or 

TCP/UDP/SOAP Server/Client service to AIS Server database(s). AIS database is 
used for History Replay and Report Generator.  

 VTS Database service: Generates and stores in the Web VTS database alarm 
events based on ship location or speed. Send safety messages. Sends virtual Aids 
to Navigation (AtoN) messages (only with AIS Base stations). 

 SNMP Client service: Receives position reports from SNMP supported device 
then converts them to AIS message format and redistributes them to different 
consumers through TCP/UDP/SOAP protocol. 

 E-mail Client service: Receives e-mail position reports from satellite tracking 
providers such as Inmarsat, Iridium, Globalstar and converts them to AIS 
messages and redistributes them to different consumers through TCP/UDP/SOAP 
protocol. 

 Run Program service: This is auxiliary service that allows running any 
scheduled Windows program.  

  
A service is a background process executed by AIS Server. 
  

 You may enable or disable services by clicking a check box in front of their 
names. 

 You may add services by selecting Edit from the main menu and choosing a new 
service. 

 You may edit service’s settings by double-click on the service name. 
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 You may delete services by choosing the service’s name and selecting Edit > 
Delete from the main menu. 
  

To launch AIS Server, you can use a shortcut on the desktop and simply double-click 
onto this shortcut or choose it from the Windows Start menu. 
  

 
  

The default settings description: 
  
After the installation AIS Server has predefined settings for the configuration with one 
AIS transponder/receiver connected through a serial port: 
  

 COM Port connection is enabled. Port number is COM1 and speed is 38400bps. 
This service allows receiving and sending AIS messages to the directly connected 
ais device.  

 History Database service is enabled . All AIS messages are being stored in 
history database split by months. 
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 SiiTech TCP connection 1 is enabled. This TCP Client service “SiiTech TCP 
connection 1” is for sending AIS messages to the first SiiTech’s server. This 
service will allow you to see your ships on SiiTech’s web site immediately after 
starting the AIS Server. This is a convenient way to test your setup. Later you 
may disable this service. 

 SiiTech TCP connection 2 is enabled. This TCP Client service “SiiTech TCP 
connection 2” is for sending AIS messages to the second SiiTech’s server. This 
service will allow you to see your ships on SiiTech’s web site immediately after 
starting the AIS Server. This is a convenient way to test your setup. Later you 
may disable this service. That is redundant service to provide uninterrupted 
service in case the first SiiTech service's failure.  

 VTS Pro Database service is enabled. New alarm events will be detected and 
stored in the Web VTS Pro database. 

 VTS Server service is enabled. This service waits for a connection with Web 
VTS and sends AIS data to Web VTS. 

 Report Database service is disabled. If it is enabled then all AIS messages are 
being stored in report database split by months. 

 SiiTech UDP connection 1 is disabled. You may enable this service and use it 
instead of "SiiTech TCP connection 1" service to send AIS data to the first 
SiiTech’s server. If you are going to use this service to send AIS messages to 
SiiTech, do not forget to disable “SiiTech TCP connection 1” service. 

 SiiTech UDP connection 2 is disabled. You may enable this service and use it 
instead of "SiiTech TCP connection 2" service to send AIS data to the second 
SiiTech’s server. If you are going to use this service to send AIS messages to 
SiiTech, do not forget to disable “SiiTech TCP connection 2” service.  

 VTS Pro Plus Database service is disabled. Use this service instead of VTS 
Server Pro, if you use Web VTS Pro Plus. 
  

Note: You may send true AIS message to SiiTech without any restrictions. 
  
If these settings fit your configuration, you do not need to make any additional changes 
and may start services by clicking on the Start button. 
  
If default AIS Server settings do not fit your configuration, you may need to change 
existing settings. Refer to the section Configuring AIS Server for more information. 
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Changing configuration 
  
You must stop the AIS Server before making any changes in the configuration. To stop 
AIS Server, press the Stop button. After you complete your changes press the Start 
button to resume AIS Server’s work. 
If you don't want to interrupt AIS Server's work during your configuration then you could 
switch to the Configured precesses panel, next make your configurations and click the 
Restart button to resume AIS Server's work.  
  
AIS Server has two panels: Configured processes and Running processes. 
To be able to switch from one panel to another click the Configured processes tab or the 
Running processes tab respectively.  
  
The Configuration processes panel shows all configured and saved processes and allows 
configuring processes without stopping AIS Server. 
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The Running processes panel shows running processes.   
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To create a new service, click the Edit menu and select the desired service  
or 
use a right mouse button when a pointer is inside the Configured processes panel. 
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To edit or delete any existing service, select the service and click the Edit menu and 
select Properties if you want to edit the service or Delete if you want to delete it 
or 
double-click on any existing service to open the shortcut menu.  
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TCP/UDP/SOAP Server service 
  
The TCP/UDP/SOAP Server service enables you to accept requests from TCP or UDP 
or SOAP clients and serve them. 
  

1. To create a TCP/UDP/SOAP Server service, select Edit > New 
TCP/UDP/SOAP Server… from the main menu. 
- or - 
To edit an existing TCP/UDP/SOAP Server service, choose the service’s name 
and select Edit > Properties… from the main menu. 
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2. Name: Enter the name for this service. You may enter any meaningful name. 
3. Port: Enter the TCP or UDP or SOAP port number to be used with this service. 

This port must be enabled in your router/firewall. Contact your network 
administrator for more details. 

4. Protocol: Select the protocol for this service. 
5. Check the Send Messages check box to allow this service to send AIS messages. 
6. Time widow: Enter amount of seconds to perform a down-sampling of AIS 

server data before sending data. 
7. Check the Receive Messages check box to allow this service to receive AIS 

messages. 
8. Check the Use Authentication check box if you use a data access login. 
9. To create user accounts to use a data access login click the Users... button and 

enter user's name, login and password (see the Users section for more 
information).  

10. To setup an alarm click the Alarms.. button and make necessary adjustments (see 
the Using Alarms section for more information). 

11. To specify filters press the Filters… button and make necessary adjustments (see 
the Using Filters section for more information). 

12. Press OK to save the settings. 

TCP/UDP Client service 
  
The TCP/UDP Client service enables you to connect to AIS data servers or services 
using TCP or UDP protocol. 
  

12 



Configuring AIS Server 

1. To create a TCP/UDP Client service, select Edit > New TCP/UDP Client… 
from the main menu. 
- or - 
To edit an existing TCP/UDP Client service, choose the service’s name and 
select Edit > Properties… from the main menu. 
  

 
  

2. Enter the name for this service. You may enter any meaningful name. 
3. Enter the host address. 
4. Enter the host port number. 
5. Select the protocol for this service. 
6. Check Send Messages check box to allow this service to send AIS messages. 
7. Check Receive Messages check box to allow this service to receive AIS 

messages. 
8. To specify filters press the Filters… button and make necessary adjustments (see 

the section Creating and editing filters for more information). 
9. Press OK to save the settings. 

  

COM Port service 
  
Before creating or editing any COM Port services make sure that a serial cable is 
plugged to a computer’s COM port and you know a number of that port, also you should 
know a baud rate of AIS device (check the manual of a transponder/receiver). The most 
of AIS transponders/receivers use 38400 bits/sec. 
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 The COM Port service enables you to communicate with AIS devices through the serial 
interface. 
  

1. To create a COM Port service, select Edit > New COM Port… from the main 
menu. 
- or - 
To edit an existing COM Port service, choose the service’s name and select Edit 
> Properties… from the main menu. 

  

 
  

2. Enter the name for this service. You may enter any meaningful name. 
3. Select the COM port. 
4. Select the serial connection speed, in bits per second (bps). 
5. Select the number of data bits in each character that is transmitted and received. 
6. Select the type of error checking. 
7. Select the number of stop bits. 
8. Select how the flow of data is controlled. 
9. Check Send Messages check box to allow this service to send AIS messages. 
10. Check Receive Messages check box to allow this service to receive AIS 

messages. 
11. Press OK to save the settings. 

  

Message Logger service 
  
The Message Logger service enables you to store all received raw AIS messages in the 
text files. 
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1. To create a Message Logger service, select Edit > New Message Logger… from 

the main menu. 
- or - 
To edit an existing Message Logger service, choose the service’s name and 
select Edit > Properties… from the main menu. 
  

 
  

2. Enter the name for this service. You may enter any meaningful name. 
3. Select the folder to store log files. 
4. To specify filters press the Filters… button and make necessary adjustments (see 

section Creating and editing filters for more information). 
5. Press OK to save the settings. 

  

VTS Server service 
  
The VTS Server service provides real-time AIS data to Web VTS. 
  

1. To create a VTS Server service, select Edit > New Message Logger … from the 
main menu. 
- or - 
To edit an existing VTS Server service, choose the service’s name and select 
Edit > Properties… from the main menu.   
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1.  
  
2. Enter the name for this service. You may enter any meaningful name. 
3. Enter the port number to be used with this service. Contact your network 

administrator for more details. 
4. To specify filters press the Filters… button and make necessary adjustments 

(see the section Creating and editing filters for more information). 
5. Press OK to save the settings. 

  

AIS Database service 
  
The AIS Database service enables you to store all received AIS data in the database. 
  

1. To create an AIS Database service, select Edit > New AIS Database… from the 
main menu. 
- or - 
To edit an existing AIS Database service, choose the service’s name and select 
Edit > Properties… from the main menu. 
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2. Enter the name for this service. You may enter any meaningful name. 
3. If you are using default installation settings and default AIS database, skip this 

step and go to step 4.  Otherwise edit SQL server name and database name (see 
the section SQL Server Connection strings for more information). You do not 
need to make any changes if you are using default installation settings. 

4. Use the Split database drop list to determine the period of time each part of AIS 
database will represent. Splitting AIS database allows you to reduce the size of 
the current working database while storing unlimited history data. 

5. Enter the number of days AIS data must be kept in AIS database. 
6. To specify filters press the Filters… button and make necessary adjustments (see 

the section Creating and editing filters for more information). 
7. Press OK to save the settings. 

  

VTS Database service 
  
The VTS Database service enables you to generate alarm events based on ships location 
or speed data. 
  
Note: Web VTS must already be installed on the computer. 
  

1. To create a VTS Database service, select Edit > New VTS Database… from the 
main menu. 
- or - 
To edit an existing VTS Database service, choose the service’s name and select 
Edit > Properties… from the main menu. 
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2. Enter the name for this service. You may enter any meaningful name. 
3. If you are using default installation settings and default Web VTS database, skip 

this step and go to step 4.  Otherwise edit SQL server name and database name 
(see the section SQL Server Connection strings for more information). You do 
not need to make any changes if you are using default installation settings. 

4. Enter the number of days the alarm events must be kept in the Web VTS database. 
5. Press OK to save the settings. 

  

Startup options 
  
You may change AIS Server’s startup options. 
  

1. To edit startup options select File > Options… from the main menu. 
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2. Select the Start Server when loaded check box to start AIS Server when loaded. 
3. Select the Load Server at Windows startup (run as service) check box to load 

AIS Server when Windows starts on the computer. 
  
Note: Loading AIS Server at Windows startup and starting AIS Server 
when loaded will make AIS Server ready to process AIS messages when 
AIS Server’s computer is switched on, even if no user is logged on to 
Windows. 

  
4. Select the Minimize Server when loaded check box to minimize AIS Server into 

an icon in the system tray when loaded. 
5. Press OK to save the settings. 

  



 

Users 

Creating and editing users 
  
To create a user, click the Users button, next right click on the Users dialog and select 
New User… from the context menu. 
- or - 
To edit an existing user, double click on the user’s name. 
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1. Enter the user's name for new user. You may enter any meaningful name. 
2. Enter the user's login. You may enter any meaningful login. 
3. Enter the user's password.  
4. Click the OK button to finalize your settings. 

  



 

Using Alarms 

Creating and editing alarms 
  
To create an alarm, click on the Alarms button, next make a right click in the Email 
Alarms panel and select New Email Alarms… from the context menu. 
- or - 
To edit an existing alarm, right click on the alarm’s name and select Properties… from 
the context menu. 
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1. Name: Enter the name for this alarm. You may enter any meaningful name. 
2. Incoming traffic (Check every): Type number of minutes in the Check every 

box to check periodically for presence of the Incoming traffic. 
3. Incoming traffic (Email every): Type number of minutes in the Email every to 

send an e-mail alarm periodically.  
4. Outgoing traffic (Check every): Type number of minutes in the Check every 

box to check periodically for presence of the Outgoing traffic. 
5. Outgoing traffic (Email every): Type number of minutes in the Email every 

box to send an e-mail alarm periodically. 
6. Server connections (Check every): Type number of minutes in the Check every 

box to check periodically server connections. 
7. Server connections (Email every): Type number of minutes in the Email every 

box to send an e-mail alarm periodically.  
8. List of email addresses separated by semicolons(;): Type e-mail addresses in 

this box to send an e-mail alarm. 
9. Email text: Type an e-mail text in this box. 
10. Include diagnostic information in emails: Select this check box to include 

diagnostic information in this e-mail. 
11. Press OK to save the settings.  

  
   The alarm is presented in the Email Alarms window, see below: 
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SMTP Server Settings 
  
To be able to send a nidification alarm e-mail you have to configure your outgoing mail 
server (SMTP Server). 
  
1. To make SMTP Server Settings, click on the Alarms button, next click the Settings 
button and type your settings into the SMTP Server Settings dialogue. 
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2. Enter the Sender's Email. 
3. Enter the Domain name. 
4. Enter the SMTP Server name. 
5. Enter the port. 
6. Enter the login. 
7. Enter the password. 
8. To finalize the settings, click OK. 
  
  
  



 

Using Filters 

Creating and editing filters 
  

1. To create a filter, right click on the Filters dialog and select New Filter… from 
the context menu. 
- or - 
To edit an existing filter, right click on the filter’s name and select Properties… 
from the context menu. 
  

 
  

2. Enter the name for this filter. You may enter any meaningful name. 
3. Select necessary IP Address conditions or add new ones. 
4. Choose a logical operation to combine multiple IP Address conditions. 
5. Select necessary MMSI conditions or add new ones. 
6. Choose a logical operation to combine multiple MMSI conditions. 
7. Select necessary zone conditions or add new ones. 
8. Choose a logical operation to combine multiple zone conditions. 
9. Choose a logical operation to combine IP Address, MMSI, and zone condition 

groups. 
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10. Specify the action for this filter. 
  

IP Address condition 
  

1. To create an IP Address condition, right click on the Filter dialog and select New 
IP Address Condition… from the context menu. 
- or - 
To edit an existing IP Address condition, right click on the filter’s name and 
select Properties… from the context menu. 

  

 
  

2. Enter the name for this condition. You may enter any meaningful name. 
3. Enter the source IP addresses or domain names separated by semicolons (;). 
4. Enter the destination IP addresses or domain names separated by semicolons (;). 
5. Specify when the message meets this condition. 
6. Press OK to save the settings. 

  
Note 1: You may specify IP addresses with or without port number (e.g. 
192.168.0.1:9009 or 192.168.0.1). If the port number is omitted then the condition is 
affecting all ports for the specified IP address. 
  
Note 2: In IP Address conditions you may refer to COM Port, AIS Database, and 
VTS Database services using the following IP addresses: 
  

0.0.0.1  – COM Port service 
0.0.0.2  – AIS Database service 
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0.0.0.3  – VTS Database service, sends AIS safety messages 
0.0.0.4  – VTS Database service, sends AIS AtoN messages 

  

MMSI condition 
  

1. To create an MMSI condition, right click on the Filter dialog and select New 
MMSI Condition… from the context menu. 
- or - 
To edit an existing MMSI condition, right click on the filter’s name and select 
Properties… from the context menu. 
  

 
  

2. Enter the name for this condition. You may enter any meaningful name. 
3. Enter the MMSI numbers separated by semicolons (;). 
4. Specify when the message meets this condition. 
5. Press OK to save the settings.  

  
  
  

Zone condition 
  

1. To create a zone condition, right click on the Filter dialog and select New Zone 
Condition… from the context menu. 
- or - 
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To edit an existing zone condition, right click on the filter’s name and select 
Properties… from the context menu. 

  

 
  

2. Enter the name for this filter. You may enter any meaningful name. 
3. Enter geographical coordinates of the filter’s rectangular area. 
4. Specify when the message meets this condition. 
5. Press OK to save the settings.  

  

Filter Examples 
  

Let’s assume that we are connected to three AIS data sources (source X with IP 
address X.X.X.X, source Y with IP address Y.Y.Y.Y, and source Z with IP address 
Z.Z.Z.Z) and three customers are connected to our server (customer A with IP address 
A.A.A.A, customer B with IP address B.B.B.B, and customer C with IP address 
C.C.C.C). And we want customer A to receive AIS messages only from source X, 
customer B to receive AIS messages only from sources Y and Z, and customer C to 
receive all AIS messages. All other unspecified customers must not receive any AIS 
messages. 
  

  
Allow customer A to receive AIS messages only from source X 
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1. Select the service that is used to send AIS data to customers and select Edit > 

Properties… from the main menu. 
2. Press the Filters… button to open Filters dialog. 
3. Right-click the list of filters, and then select New Filter… from the context menu 

to open Filter dialog. 
4. In Filter dialog, enter ”r;X->A filter” string in the Name box. 
5. Right-click the IP Address Conditions list, and then select New IP Address 

Condition… from the context menu to open IP Address Condition Properties 
dialog. 

6. In IP Address Condition Properties dialog, enter ”r;X->A” string in the Name 
box. 

7. Enter IP address of AIS data source X in the Source IP addresses or domain 
names box. 

8. Enter IP address of client A in the Destination IP addresses or domain names 
box. 

9. Under The message meets this condition if it is, select In the specified address 
range. 

   

  

 
  

where X.X.X.X is an IP address of AIS data source X, and A.A.A.A is an IP 
address of client A 
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10. Press OK to save the properties and to close IP Address Condition Properties 
dialog. 

11. In Filter dialog, under Action, select Enable messages if conditions are met. 
  

 
  

12. Press OK to save the settings and to close Filter dialog. 
13. In Filters dialog, under Action for unfiltered messages, select Disable all 

unfiltered messages. 
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14. Press OK to save the settings and to close Filters dialog.  
  
  
Allow customer B to receive AIS messages only from sources Y and Z 
  

1. Select the service that is used to send AIS data to customers and select Edit > 
Properties… from the main menu. 

2. Press the Filters… button to open Filters dialog. 
3. Right-click the list of filters, and then select New Filter… from the context menu 

to open Filter dialog. 
4. In Filter dialog, enter ”r;Y,Z->B filter” string in the Name box. 
5. Right-click the IP Address Conditions list, and then select New IP Address 

Condition… from the context menu to open IP Address Condition Properties 
dialog. 

6. In IP Address Condition Properties dialog, enter ”r;Y,Z->B” string in the Name 
box. 

7. Enter IP addresses of AIS data sources Y and Z in the Source IP addresses or 
domain names box. 

8. Enter IP address of client B in the Destination IP addresses or domain names 
box. 

9. Under The message meets this condition if it is, select In the specified address 
range. 
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where Y.Y.Y.Y is an IP address of AIS data source Y, Z.Z.Z.Z is an IP address 
of AIS data source Z, and B.B.B.B is an IP address of client B 

  
10. Press OK to save the properties and to close IP Address Condition Properties 

dialog. 
11. In Filter dialog, under Action, select Enable messages if conditions are met. 
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12. Press OK to save the settings and to close Filter dialog. 
13. In Filters dialog, under Action for unfiltered messages, select Disable all 

unfiltered messages. 
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14. Press OK to save the settings and to close Filters dialog.  
  
  
Allow customer C to receive all AIS messages 

  
1. Select the service that is used to send AIS data to customers and select Edit > 

Properties… from the main menu. 
2. Press the Filters… button to open Filters dialog. 
3. Right-click the list of filters, and then select New Filter… from the context menu 

to open Filter dialog. 
4. In Filter dialog, enter ”r;all->C filter” string in the Name box. 
5. Right-click the IP Address Conditions list, and then select New IP Address 

Condition… from the context menu to open IP Address Condition Properties 
dialog. 

6. In IP Address Condition Properties dialog, enter ”r;all->C” string in the Name 
box. 

7. Enter ”r;*.*.*.*” string in the Source IP addresses or domain names box. 
8. Enter IP address of client C in the Destination IP addresses or domain names 

box. 
9. Under The message meets this condition if it is, select In the specified address 

range. 
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where C.C.C.C is an IP address of client C 
  

10. Press OK to save the properties and to close IP Address Condition Properties 
dialog. 

11. In Filter dialog, under Action, select Enable messages if conditions are met. 
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12. Press OK to save the settings and to close Filter dialog. 
13. In Filters dialog, under Action for unfiltered messages, select Disable all 

unfiltered messages. 
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14. Press OK to save the settings and to close Filters dialog.  
  

Now we have three filters for the service that is used to send AIS data to customers. 
Customer A will receive AIS messages only from source X, customer B will receive 
AIS messages only from sources Y and Z, and customer C will receive all AIS 
messages. All other unspecified customers will not receive any AIS messages. 
  



 

SQL Server Connection strings 
  
This is a compiled connection strings reference list on how to connect to SQL Server. 
  
Standard Security for SQL Server 2005 Express Edition 
  
Driver={SQL Native Client};Server=.\SQLExpress;Database=database;Uid=username; 
Pwd=password; 
  

Example: 
  
Driver={SQL Native Client};Server=.\SQLExpress;Database=AIS;Uid=sa;Pwd=sql; 
  
  

Trusted connection for SQL Server 2005 Express Edition 
  
Driver={SQL Native 
Client};Server=.\SQLExpress;Database=database;Trusted_Connection=yes; 
  

Example: 
  
Driver={SQL Native 
Client};Server=.\SQLExpress;Database=AIS;Trusted_Connection=yes; 
  
  

Standard Security for SQL Server 2005 
  
Driver={SQL Native Client};Server=serverAddress;Database=database;Uid=username; 
Pwd=password; 
  
Driver={SQL Native 
Client};Server=serverAddress:port;Database=database;Uid=username; 
Pwd=password; 
  

Example: 
  
Driver={SQL Native Client};Server=192.168.0.10;Database=AIS;Uid=sa;Pwd=sql; 
  
Driver={SQL Native 
Client};Server=192.168.0.10:1433;Database=AIS;Uid=sa;Pwd=sql; 
  
  

Trusted connection for SQL Server 2005 
  
Driver={SQL Native 
Client};Server=serverAddress;Database=database;Trusted_Connection=yes; 
  
Driver={SQL Native Client};Server=serverAddress:port;Database=database; 
Trusted_Connection=yes; 
  

Example: 
  
Driver={SQL Native 
Client};Server=192.168.0.10;Database=AIS;Trusted_Connection=yes; 
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Driver={SQL Native 
Client};Server=192.168.0.10:1433;Database=AIS;Trusted_Connection=yes; 
  
  

Standard Security for SQL Server 2000 
  
Driver={SQL 
Server};Server=serverAddress;Database=database;Uid=username;Pwd=password; 
  
Driver={SQL Server};Server=serverAddress:port;Database=database;Uid=username; 
Pwd=password; 
  

Example: 
  
Driver={SQL Server};Server=192.168.0.10;Database=AIS;Uid=sa;Pwd=sql; 
  
Driver={SQL Server};Server=192.168.0.10:1433;Database=AIS;Uid=sa;Pwd=sql; 
  
  

Trusted connection for SQL Server 2000 
  
Driver={SQL 
Server};Server=serverAddress;Database=database;Trusted_Connection=Yes; 
  
Driver={SQL 
Server};Server=serverAddress:port;Database=database;Trusted_Connection=Yes; 
  

Example: 
  
Driver={SQL Server};Server=192.168.0.10;Database=AIS;Trusted_Connection=yes; 
  
Driver={SQL 
Server};Server=192.168.0.10:1433;Database=AIS;Trusted_Connection=yes; 
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